• Thanks for visiting the Kaleidescape Owners' Forum

    This forum is for the community of Kaleidescape owners, and others interested in learning about the system, equipment, services, and the company itself.

    It is run by a group of enthusiastic Kaleidescape owners and dealers purely as a service to this community.

    This board is not affiliated in any way with Kaleidescape, Inc.
    For official technical support, product information, or customer service, please visit www.kaleidescape.com

  • You are currently in "Guest" mode and not logged in with a registered account.

    The forum is free to use and most of the forum can be used by guests who are not registered....

    ... but we strongly encourage you to register for a full account. There is no cost to register for a full account.

    Benefits of registering for a full account:

    • Participate in the discussions! You must have a registered account to make posts on the forums. You will be able to start your own thread on a topic or question, or you can reply to other threads/discussions.
    • Use the "Conversation" feature (known as "private messaging" on other forums) to communicate directly with any of the other users here.
    • Access the Files area. The "resources" area of the forum contains many "Favorite Scene" and Script files that can dramatically increase the enjoyment of your Kaleidescape system. Go directly to great scenes in your favorite movies, created by other owners, and add automation to playback of your system with Scripts.
    • You won't see this annoying notice at the top of every screen!😊

    It's easy and free to register for the forum. Just click the "Register" button in the upper right corner of this page, and follow the instructions there.

Kaleidescape Lost Music Metadata

cinelife

Administrator
Staff member
Forum Administrator
Moderator
⭐️⭐️PATRON⭐️⭐️
Authorized Kaleidescape Dealer
This is likely a similar problem as that described in the link you cited. K probably already knows, but I'll forward your findings to them right away.



Jim
 
Many thanks for your assistance Jim.

I have emailed K Support with an excel export and component details.

There has been one or two occasions where album art has been lost but this one has come as a bit of a shock...
 
After startup the music section suffered 'black holes'

https://1drv.ms/i/s!AnaaJYW8KT28guwMhiu3-bcSbrQRbw
s!AnaaJYW8KT28guwMhiu3-bcSbrQRbw


After a reset I got the 'Unknowns'

https://1drv.ms/i/s!AnaaJYW8KT28guwJIvgZJOfYxQNHbg
s!AnaaJYW8KT28guwJIvgZJOfYxQNHbg
 
Last edited:

fizzsnob

Active member
After startup the music section suffered 'black holes'

After a reset I got the 'Unknowns'

I just noticed that I appear to have a similar problem; Many of my albums are now "unknown".

My FW has not been updated in months; It has to be something else that changed.

And I have definitely imported other content since this has happened, since I didn't notice. If that other forum link is correct, I am hosed...


Mike
 

SHOEMAN

Well-known member
I just sat down to watch a movie tonight and saw on the music that I have over 1800 cds turned all to unknown albums. Must have happened in the last 24 to 48 hours. My software version is 6.2.2-15767 and that was upgraded back in April. I hope they can put back or this will be a huge winter project. Im on my knees praying K can get it back.
Shoeman
 

MikeKobb

Well-known member
◥ ◣ Kaleidescape, Inc.
Howdy folks,

I don't have any hard info to share yet. Just wanted to assure you that we've been alerted to the problem and it is being investigated. As soon as I have any useful info to share, I'll let you know!
 

bryeden

Member
Also have the same problem with unknown albums, missing cover art and where I can get to an actual disc the song list just says "Track 1, 2,3" etc. This seemed to have happened after the recent datacentre issue.
I won't e-mail support as from the comments in this thread they seem to have picked up the problem
 

MikeKobb

Well-known member
◥ ◣ Kaleidescape, Inc.
Good morning, folks! Investigation is proceeding actively at this time. Early information is that it appears that there's a problem with the process that generates the music guide that's downloaded to your systems. That's why these albums are appearing as unrecognized -- their information is missing from the latest music guide updates.

Fixing whatever that problem is with guide generation should cause these albums to regain their information automatically.

Regarding the information from the old 2009 thread (that importing something could cause problems with restoring information) -- I don't know whether that's relevant in this situation or not. I'm trying to find out right now. As far as I know, that would only affect situations in which you have manually entered album information, if it applied at all.

I'll post more information as soon as I have some.
 

cinelife

Administrator
Staff member
Forum Administrator
Moderator
⭐️⭐️PATRON⭐️⭐️
Authorized Kaleidescape Dealer
Thanks Mike, I was just about to post same info (your are too fast!:D).





Jim
 

Mark H

Well-known member
⭐️⭐️PATRON⭐️⭐️
I have not only missing art work but over 2200 albums are missing from the music screen and are not shown as available to play but are reported on the home screen in the count of albums. Also noticed that the free space had increased on one of my servers in 'the cluster' but there is nothing in the trash as both trash bins are empty which I am sure is also wrong
 

MikeKobb

Well-known member
◥ ◣ Kaleidescape, Inc.
Hello again, all. Just another quick update. We're testing a fixed version of the music guide data now. Assuming that it looks good, we will deploy it to the update servers, and systems will download it and process it. We're hopeful that this will start today, in which case systems should be back to normal late today or sometime tomorrow.

Out of an abundance of caution, it's probably best to avoid importing content or making manual changes to album information in the meantime.

Point of interest for the computer geeks: this problem does appear to be related to the network outage that affected our datacenter last week. The interruption in network connectivity happened to during the automatic creation of a music guide update, and that interruption caused the guide data to be incomplete. A failure of that type should have been detected, causing the guide preparation to abort. But, there was a bug that meant that a failure at that exact stage didn't get detected properly. We've fixed that bug as well, so in the very unlikely event of an identical failure in the future, this shouldn't happen again.
 

Mark H

Well-known member
⭐️⭐️PATRON⭐️⭐️
I await with 'baited breath' as the music guide process has always been 'buggy' in that missing artwork that you manually add so as to have cover art for all albums just disappears randomly over time but this outage is major and different.

My biggest worry is why have nearly all my albums disappeared and the available storage increased on one of my servers where the albums are stored and yet none are in the trash! Perhaps the music guide fix will fix this to.

Saw a similar situation some months back when suddenly the available storage increased by 10% and I found several hundred DVD / BluRays in the trash despite me not doing anything - luckily I was able to restore them to the library without data loss.
 

MikeKobb

Well-known member
◥ ◣ Kaleidescape, Inc.
Hi Mark,

I spoke with some of the folks involved, and we think the reason you saw an increase in free space may be that when albums become unrecognized, the downloaded cover artwork and artist portraits get deleted.

Not sure how much your free space went up, but this could be the cause (plus the incomplete guide data itself was also substantially smaller).

Just sit tight, don't import or edit metadata on anything for now, and once the guide data is restored we'll hopefully see everything back to normal.
 

Mark H

Well-known member
⭐️⭐️PATRON⭐️⭐️
OK will do as is time for bed here in Europe.

I do worry as why does the library only show 38 CD's on the music page rather than 2000+ that were in the library and free space has increased over 200Gb so that is a lot of artwork so I think the problem is bigger - I have emailed the screen prints to support so they have the data and server serial numbers.
 

mpnsoft

New member
I have the same problem with 570 CD's on my 3U server. I tried calling... they were always great in the past. There seems to be a full-time voicemail box now. I miss my music and am concerned about the prospect of getting things working again. The Kaleidescape system is the electronic entertainment backbone of my home. Is it time to look for a replacement?
 
Many thanks Mike & Jim, good to know things have moved forward at K so quickly after I reported the fault on these pages.

As with Mark H I'll be off to bed soon so I'll check the system tomorrow to see if the albums return.
 
Top