• Thanks for visiting the Kaleidescape Owners' Forum

    This forum is for the community of Kaleidescape owners, and others interested in learning about the system, equipment, services, and the company itself.

    It is run by a group of enthusiastic Kaleidescape owners and dealers purely as a service to this community.

    This board is not affiliated in any way with Kaleidescape, Inc.
    For official technical support, product information, or customer service, please visit www.kaleidescape.com

  • You are currently in "Guest" mode and not logged in with a registered account.

    The forum is free to use and most of the forum can be used by guests who are not registered....

    ... but we strongly encourage you to register for a full account. There is no cost to register for a full account.

    Benefits of registering for a full account:

    • Participate in the discussions! You must have a registered account to make posts on the forums. You will be able to start your own thread on a topic or question, or you can reply to other threads/discussions.
    • Use the "Conversation" feature (known as "private messaging" on other forums) to communicate directly with any of the other users here.
    • Access the Files area. The "resources" area of the forum contains many "Favorite Scene" and Script files that can dramatically increase the enjoyment of your Kaleidescape system. Go directly to great scenes in your favorite movies, created by other owners, and add automation to playback of your system with Scripts.
    • You won't see this annoying notice at the top of every screen!😊

    It's easy and free to register for the forum. Just click the "Register" button in the upper right corner of this page, and follow the instructions there.

Trying to import scripts


Well-known member
I have downloaded a number of movies and was provided scripts from another K user that utilize those movies but I get some errors. (see below). He has re-sent the scripts but I get the same error both times. In this example, it notes the Han Zimmer movie is not in my library, but it is.Screen Shot 2021-10-20 at 9.18.49 AM.pngBut then it gives me the following error message:
Screen Shot 2021-10-20 at 9.19.10 AM.png


  • Screen Shot 2021-10-20 at 11.02.43 AM.png
    Screen Shot 2021-10-20 at 11.02.43 AM.png
    26.7 KB · Views: 8


Well-known member
◥ ◣ Kaleidescape, Inc.
It's not quite as simple as having the same movie title in your library. In order to import the script you have to have the exact same media object (i.e. same quality and format) as the one the script is referring to.

At a simple level, this means that if the script points to a version of the Hans Zimmer title that is on a Blu-ray Disc but you have the HD download, then they don't match. The same would be true for the script pointing to a UHD download and you have the HDR download. In the case of disc-based content, two different Blu-ray Discs (or DVDs) for the same movie (e.g. one from the US and one from the UK) could be seen as different media objects by our recognition process.

It can get even more complicated when you start talking about upgraded media objects. For example, the script could be pointing at an HD download from our store that has subsequently been replaced (on our store) by a newer version (e.g. the original release had a Dolby 5.1 audio track and we upgraded it to an Atmos track). In this case, the newer download is seen as a different version than the older one.

So the dialog in your screenshot above is letting you know that you don't have the exact same media object on your system that the other user has on theirs.

The second dialog is presented when either:
a) the script .dat file is corrupted in some way; or,
b) the .dat file is actually a scenes export rather than a script file.


Well-known member
◥ ◣ Kaleidescape, Inc.
Having said all of the above, you shouldn't see the second dialog as result of trying to import the script that you post in the first dialog. Just setting up a test here to see if I can replicate the behaviour in-house.


Well-known member
◥ ◣ Kaleidescape, Inc.
I just ran a quick test by downloading the Trinnov script that is posted here on the Owner's forum and then importing it to my test system. I did it twice: once when only one of the titles referenced in the script was present on my system (which essentially replicates your scenario) and once with both titles on my system.

Both times, the script imported without error. This makes me suspect that the .dat file you have is corrupted in some way but I'm not ready to completely rule out a kOS bug just yet.

Will you PM me and send me the script .dat file please? Additionally, if you have a minute, please try to import that .dat file one more time (so that it'll be in your recent logs) and include the serial number of the server that you tried to import the file to. That will let me look at your logs to see if there is anything interesting reported during the import attempt.