Kaleidescape Owners' Forum   Kaleidescape, Inc. Kaleidescape, Inc.

Go Back   Kaleidescape Owners' Forum > Hardware & Setup Threads > Kaleidescape Hardware & Setup

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old Mar 10th, 2018
flitebynite's Avatar
flitebynite flitebynite is offline
Member
 
Join Date: Mar 2017
Location: Cutler Bay, Florida
Posts: 54
Default Where did my Movies go?

I am missing almost 700 movies.
I recently bought 4 new 6TB drives for my 1U server. I replicated all of my old content from my other 1U servers to the new unit and it showed I had approximately 22% storage capacity remaining. Everything has been great for a couple weeks, until this Morning.
I opened the browser interface and I had a message the M700 player/Vault needed to eject 169 blue ray disks. There were a total of 213 Blue rays in the Vault. I didn't eject them right away, I didn't understand why they would need to be ejected so I wanted to do some troubleshooting.
I looked at the browser interface again to check the server statuses and found there are only 72 Movies and 261 music albums. WTF?
The new server disks show now there is 87% free space and the second server shows 99% free space.
I now have the 44 Blue rays and 28 of my over 500 DVD's I had saved.
I don't get it.
Has anyone ever had this happen before? Have I done something wrong?
Can anyone give me some insight into what has happened?
I have a speed reader, but I don't want to have to reload all of my Movies if I don't have to.
Thanks in advance to anyone who can help.
Regards,
Chris
Reply With Quote
  #2  
Old Mar 10th, 2018
flitebynite's Avatar
flitebynite flitebynite is offline
Member
 
Join Date: Mar 2017
Location: Cutler Bay, Florida
Posts: 54
Default

I found my Movies!
They were in my Trash file.
I didn't delete them.
Does anyone have any idea how this could have happened?
Chris
Reply With Quote
  #3  
Old Mar 11th, 2018
MikeKobb MikeKobb is offline
Kaleidescape, Inc.
 
Join Date: Oct 2015
Location: Sunnyvale, CA
Posts: 586
Default

Chris, the only interface on a Premiere system for putting movies into the trash is the system's browser interface. (It's not available through the onscreen display, etc.)

Is it possible that somebody might have been using the browser interface and mistakenly clicked "Move to Trash" instead of "Add to Collection"? The buttons are adjacent.
Reply With Quote
  #4  
Old Mar 14th, 2018
flitebynite's Avatar
flitebynite flitebynite is offline
Member
 
Join Date: Mar 2017
Location: Cutler Bay, Florida
Posts: 54
Default

I'm the only one who has access to the system. (I live alone)
It seemed to happen when I hooked up the second 1U server.
Reply With Quote
  #5  
Old Mar 14th, 2018
MikeKobb MikeKobb is offline
Kaleidescape, Inc.
 
Join Date: Oct 2015
Location: Sunnyvale, CA
Posts: 586
Default

Hi Chris,

One of our other engineers read your postings, and I think he has identified the issue. It seems that you replicated from your original 1U to the new one, and then grouped the two servers together. This is not how replication is designed to be used. It's intended to be a one-way trip to a new system. It's likely that you have duplicated data on your two servers right now, and some behavior is potentially unpredictable.

We'd recommend opening a support case so that our engineering team can connect to your system and see what sort of state things are in.
Reply With Quote
  #6  
Old Mar 19th, 2018
flitebynite's Avatar
flitebynite flitebynite is offline
Member
 
Join Date: Mar 2017
Location: Cutler Bay, Florida
Posts: 54
Default

Thank you for your help MikeKobb.
Do I need to have my dealer (Cinelife) submit the tech request?
Please let me know.
Thanks,
Reply With Quote
  #7  
Old Mar 19th, 2018
cinelife cinelife is offline
 
Join Date: Jul 2006
Location: Florida, Indiana, California, Honolulu
Posts: 3,170
Default

Reach out when you have time, I'll check on the support issues tomorrow.

Jim
Reply With Quote
  #8  
Old 1 Week Ago
flitebynite's Avatar
flitebynite flitebynite is offline
Member
 
Join Date: Mar 2017
Location: Cutler Bay, Florida
Posts: 54
Default

I found this in the tips and tricks section.
This exactly what happened to me when my movies disappeared.

Quote:
Originally Posted by brodricj View Post
When grouping servers, any content that is in the trash of one server, kOS will automatically move any duplicate content in the movie/music library of the other server into the trash as well. Resulting in that content "disappearing" from your library!

My scenario was this. File systems A and B were in a group which reached 99% capacity. I replicated all the content from A/B onto new file system C and then removed A/B from the group (meaning C was then operating alone). All the content on A/B was then put in the trash, so A and B each showed no content in their respective movie/music libraries, and full capacity showing available for future use.

Eventually when file system C reached 99% capacity I added "empty" file system B to the group. I then checked my music library and to my horror virtually all my CD albums were missing from the UI! Phone call to Support

What happened was, because B had previously been replicated onto C, when the B/C group was made there were 2 copies of all my CD albums on the system (one copy being in the trash of B, and the other copy being in the library of C). kOS then put all the duplicate copies into the trash, meaning the only albums showing in my UI were those I had imported after the A/B>C replication.

The corrective action was to remove each album from the trash and return it to the library. The difficulty with this is the content might end up on B, or it might end up on C, depending on where kOS decides to put it. So when I can afford to buy file system D (so I don't need to run 2 servers), I'm going to have to replicate content from both B>D and C>D.

This problem would have been averted if I had first emptied the trash of B before making the B/C group. My movie library has also been affected in some way, but I haven't been able to unravel yet exactly how so, or how to fix it (I suspect all the movie content in the trash of B won't now fit in the B/C group if I try to move it back into the movie library like I did for the music albums).

The other thing which caught my attention was in the new B/C group, the 1-year old movie/music db update status on B took precedence over the current movie/music db status on C. Meaning some of my movie content on the system regressed back into the "movies missing video bookmarks" collection, despite that content having been previously processed for video bookmarks (i.e. that which was processed in the intervening time between the old update on B and the current update on C).

If I had emptied the trash on B before joining the B/C group in the first place then none of this would have been an issue. Which is why I suggest, empty the trash before putting 2 servers in the same group. I was so glad I called K Support for assistance, because I was about to permanently delete my trash thinking that would be a fix when a very loud shout came down the phone line "no, don't do that". I was only moments away from having to re-import about 249 CD albums
Reply With Quote
  #9  
Old 1 Week Ago
MikeKobb MikeKobb is offline
Kaleidescape, Inc.
 
Join Date: Oct 2015
Location: Sunnyvale, CA
Posts: 586
Default

To elaborate just a bit further -- replication is designed to completely duplicate the contents of one system when you are migrating to a new system. It is not intended to be used if the original source system will ever be re-joined with the destination system, because there will be duplication of internal data that may cause unpredictable behavior.
Reply With Quote
  #10  
Old 1 Week Ago
flitebynite's Avatar
flitebynite flitebynite is offline
Member
 
Join Date: Mar 2017
Location: Cutler Bay, Florida
Posts: 54
Default

I understand now what I did wrong.
My intent was to move on to a 3U server, but that didn't work out. So I put the second 1U back in the system.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:55 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright ?2006 - KscapeOwners.com.
THIS SITE IS NOT OWNED BY, OPERATED BY, OR AFFILIATED IN ANY WAY WITH KALEIDESCAPE INC.
"Kaleidescape" is a trademark of Kaleidescape, Inc.; it is registered in some jurisdictions.